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1. Introduction

If you wish to tabulate information, i.e. arrange data in the form of rows and columns and
manipulate and analyses it, a spreadsheet application is the right package for you. There are
a number of spreadsheet software’s. Among these are: Lotusl-2-3, Quattro Pro, and
MS-Excel.  Ms-Excel is the most popular electronic spreadsheet application software. If
the job at hand requires: lots of lists, tables, financial calculations, analysis and graphs,

Excel is just the package for you.

2. Starting MS- Excel

» To start MS- Excel:
% Click the Start button
% Point to Programs

% Click MS- Excel

Note: There are also several short cut methods for starting MS-Excel.
v Make (create) a shortcut icon on the Desktop, and open it by double clicking the
icon.
v Double click MS-Excel icon from MS- Office shortcut bar if it is displayed on the
Desktop.
v Using start up, you can make MS-Excel to start automatically whenever you turned

on your computer.
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3. Components of a Workbook

When you start MS-Excel, the inner blank workbook and the Menu bar, Tool bars,

Scrollbars, and Title bar, Control menu, Start button, etc are displayed.

Workbook: The file in which you work and store your data is known as a workbook, which

consists of worksheets. By default, three worksheets are displayed on the
sheet tab on a workbook, although there are up to 16 worksheets.

To open a new work book

¢+ Click new from the File menu

% Click the General tab

%+ Double-click the Workbook icon

The following figure shows the components of a workbook.
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Worksheet: A worksheet is what you really call an electronic spreadsheet. In a workbook,
you can perform calculations on several worksheets simultaneously.
Worksheets have the names Sheet 1, Sheet 2, Sheet 3, etc. These names are
displayed on sheet tabs. To make worksheet names more descriptive, you can
rename the worksheet by right clicking on the sheet tab, choose Rename and
type the new name. A worksheet is made up of rows and columns. A number
called Row Heading labels each row and a letter called Column Heading
labels each column. There are 65,536, Rows and 255 Columns in a
worksheet. The column names starting from the first column vary as A, B, C,
Z, AA, AB, AC, ...IV, while row names starting from the first row in a
worksheet vary as 1,2,3...65,536.

Title bar: is used to display the name of the workbook you are working on. When a
workbook window is maximized you will see the application and workbook
name altogether on a single title bar.

Column Heading: letters just below the workbook title bar or below the formula bar (if the
work book window is maximized) that represents columns. In MS-Excel
2000, a single worksheet has 256 columns labeled alphabetically A to IV.

Row Headings: are numbers that represents rows. In MS-Excel 2000, a single worksheet
has 65,536 rows labeled from 1 to 65,536.

Sheet tabs: a single book can have up to 16 sheet tabs. A sheet tab displays the name of
worksheet in the active opened workbook.

Sheet tabs Scrolling buttons: Use this button to navigate through sheet tabs. These buttons
are called First tab, Previous tab, Next tab, and Last tab button.

Cell: is the smallest data entry unit in a worksheet named as a column heading followed by a

row heading as B3 (the second column and the third row).
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3.1 Creating a New Workbook

You can start a new workbook any time Excel is running. When you open one workbook

without closing the current one, the one that is already opened disappears from view and

remains in memory.

» To create a new workbook:
v" Click on the New button from the standard toolbar.
OR
v Choose File, New.
v" Click on General tab.
v Activate Workbook icon and click Ok.

3.2 Inserting, Selecting, and Deleting Worksheets

When you create a new workbook, MS-Excel displays 3 worksheets by default. But you can
determine the number of sheets to be displayed in a new workbook as follows.

¢ On the Tools menu, click Options.

¢ Click on General tab.

¢ In the Sheets in New Workbook Spinner, select the number of sheets you want to
display.

¢ Click on Ok to close the Options dialog box, and then create a new workbook to see the
effect.

» To insert a new worksheet:
e Select the sheet from the sheet tab you want to insert the new sheet to the left.
e Choose Insert and then Worksheet.

e Type a new name or accept the default name.
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OR

e Right click on the sheet you want to add the new sheet to the left of it.
e Click on Insert from the drop up menu.

e From the General tab, click Worksheet.

e Click Ok, and type a new name or accept the default name.

» To select adjacent sheets on the sheet tab:
e Click on the first sheet.

e Hold down the Ctrl key and click on the sheets you want to select.
Deleting a Worksheet

Whenever you no longer need a worksheet from your workbook, you can remove it in a
number of ways.
» To delete a worksheet:
e Activate or select the worksheet.
e Choose Edit, and then click Delete.
OR
e Right click on the sheet tab you want to delete.

e Click Delete from the pop-up menu, and then click Ok.

3.3 Hiding, Un hiding and Renaming Worksheets.

Hiding a sheet does not have any impact on the worksheet, except preventing the sheet from
being displayed in the workbook. You can use this method to hide worksheets whenever you
want to reduce the number of windows and sheets on the screen and to prevent unwanted
changes. For example, you can hide sheets that contain sensitive data.
» To hide worksheets:

e Select the worksheets you want to hide.

e Choose Format, Sheet, and Hide.
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» To unhide sheets:
e Choose Format, Sheet, and Unhide.
e Select the sheet name to unhide from the unhide dialog box.
e Click Ok.
» To rename a worksheet:
e Double click on the sheet name you want to rename from the sheet tab. Or Right click
on the sheet name you want to rename and click Rename from the pop-up menu.

e Type the new name and click outside or press Enter key.

3.4 Rows and columns

There are a number of important operations that you need to perform on rows and columns.
Some of them are hiding and un hiding, freezing and un freezing, inserting and deleting

rows and columns.

Freezing panes

MS-Excel has a mechanism, which allows you to see different areas of a large worksheet at
the same time. One of such mechanisms is divide your screen in to two or more smaller
window like structures called Panes. Panes allow you scroll on one of the pane while the
others are kept fixed. This process of splitting the screen into panes is known as freezing a

pane.

A window can be splitted in to two panes either horizontally or vertically or both. Splitting

the windows both vertically and horizontally divide the screen in to four windows.

= To freeze the top horizontal (left vertical) pane:
= Select the row below (the column to the right) of the area you want to freeze.
= Click Freeze Pane on the Window menu.
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¢ To freeze both the upper and left panes:
e Click the cell at the right corner of the area in the pane to freeze.

e Click Freeze Pane on the Window menu.

3.5 Hiding and Un hiding Rows and Columns

It is possible to put non-adjacent columns (or rows) side by side by hiding the columns (or
rows) between using the Format, Columns, and Hide command. Similarly you can unhide
the hidden row, by selecting the two rows (or columns) before and after the hidden rows (or

columns) and applying the command.

4. Entering and Manipulating Data in a worksheet

Data in a worksheet is entered in cells. A cell is a combination of rows and columns. Each
cell in a worksheet is identified by the combination of the column and row headings, where
the column heading followed by the row heading. For example, the cell in the first row and
fourth column of a work sheet is D1 and the one in fifth row and second column is B5. The
active cell is the cell, which you are working currently. Whenever you click a cell, the cell is

activated and its name is displayed in the name box.

A range of cells is any portion of a worksheet, and is referred to, using the name of the first
cell in the first row of the range, a colon and the last cell in the last row of the range. For

example, A1:C8 is a range consisting of 24 cells.
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4.1. Data Types in MS-Excel

Generally, the types of data that enter a cell could be classified in to three. These are, text,
number (value) and formula. Any combination of numeric or non-numeric characters is
considered to be text. Numbers or values are quantities on which you can perform
mathematical operations. Unlike a text and a number data type, a formula is entered in a cell
to produce other entries from the existing entries. Such entries, which are the result of
calculations, are known as calculated value. A formula in a cell is displayed both in the

formula bar and in the cell only if you select the cell.

A formula is an expression consisting of:
¢ The equal sign (=) at the beginning and brackets.
¢ Constants, numbers, names or references of cells like tax rate, Al, or A1:A20.
¢ Arithmetic operators like, +, -, *, /

¢ Functions like Sum, Average.

» To enter text or value (number):
1. Click the cell where you want to enter data.
2. Press Tab or Arrow keys to move to the next cell or click on the cell you want to
move to.

3. Press Enter to the beginning of the next row or click on the desired cell.

» To enter formula into a cell:
= Click the cell where you want to enter the formula.
= Click on the Edit formula (=) button on the formula bar or click on Paste Function
(fx) button on the standard tool bar or type an equal (=) sign from the keyboard.
= Enter your formula.

= When you finish, press Enter key or click Enter button on the formula bar.
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When you enter a formula in a cell and press the enter key, or click another cell, either the
result of the calculation or an error message is displayed. An error message is displayed if

something is wrong either in the formula itself or in the values referred by the formula.
Selecting Cells with a Mouse

» To select:
e Asingle cell, simply point and click it to make active:
e The entire row, click the row heading.
e The entire column, the column heading
e Arange of cells, click and drag.

e The entire worksheet, click on the empty button at the intersection of column and
row headings

4.2. Paste Special and Auto Fill Facility
Paste Special

Once you entered data or a formula in a cell, it can be copied easily to another cell using the
Paste Special tool or the Auto Fill Facility. The Paste Special facility could be used to copy
the content of values, text, a formula, or formats from a cell and paste it to another cell.

» To copy a formula to another cell using Paste Special:
¢ Right-click the cell or (source of data).
¢ Choose Copy from the Edit or shortcut menu.
¢ Right-click the cell where you want to copy the item (destination).
¢ Choose Paste Special to display its dialog box.
.

Choose the appropriate option.

Department of Information Communication Technology (ICT)



MS-Excel Training Manual

Auto Fill Facility

Basically, there are two methods to fill automatically data in MS-Excel. Namely, the Fill

Handle and Edit/ Fill / Series command.

Using the Fill handle: A fill handle is a black square at the right bottom corner of the
selection. It is the special tool that helps you copy formula. Formulas can be copied to
consecutive cells, and a list of serial (consecutive) items like 1, 2, Monday, Tuesday, ...
September, October, ... 2, 4, etc can be created in a row or a column using auto fill facility.
When you point to the Fill handle, the pointer changes to a black cross.

To copy contents such as text or formula to the adjacent cells or to fill in a series such as date
and time, drag the fill handle.

= To create a serial list using the Fill Handle:

1. Enter two starting values for the series. The difference between the two starting items
determines the amount by which the series is incremented.

2. Select the cell that contains the starting values.

3. To fill in the increasing order, drag down or to the right.

4. To fill in decreasing order, drag up or the left.
Using the Edit/Fill/Series command

= To create a data series using this method:
1. Enter two starting values.
2. Select the cells that you want to create the data series including the starting values
3. Choose Edit and click Series from Fill submenu.
4. From the Series in options, determine whether the series is filled across rows or down
columns.
5. Select the type of series.
6. Specify the Step and Stop Values in their appropriate text box.
7. Click Ok.
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5. Editing a Worksheet

There are many reasons to edit the contents of a worksheet. To correct misspelling, to revise
data, to fix a formula you entered incorrectly, and so on, you do editing. Editing cells content

are pretty much the same whether the cell contains text, a number, a formula, or a function.
5.1 Editing Cell Entries.

To change a cell's content, you can make the change in the formula bar or you can edit
directly in a cell.

» To edit cell contents in the formula bar:
¢ Select the cell you want to edit.
¢ Click over the text in the formula bar.
¢ Make any changes to the cell contents.
¢ To enter your changes, Press Enter or click outside.
» To edit cell contents in the cell:
¢ Double click the cell that contains the data you want to edit.
¢ Make any changes to the cell contents.

¢ Press Enter key to enter your changes, or Esc to cancel the changes.
5.2 Copying and Moving Cells

You can duplicate the cell contents and paste them in a new location by using the Copy.
When you copy, the original cells are not affected. But if you want to change the location of
cell contents, to a different location, use the Move command.
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» To copy or move cell contents:
¢ Select the cell or cells you want to copy or move.

¢ Choose Copy to copy and Cut to move. A moving boarder will surround the
selection.

¢ Select the destination cell or cells.

¢ Choose Paste from the Edit menu or standard toolbar.

» To copy or move using dragging:
¢ Select the cell or cells you want to copy or move.
¢ Position the mouse pointer over the boarder of selection. The mouse pointer changes
to an arrow.
¢ Hold Ctrl key and drag the boarder to copy or drag the boarder simply to move.

¢ Release the mouse button.
5.3 Inserting and Deleting Cells, Rows, and Columns

When you work with MS-Excel worksheet, you may want to insert a blank cell, row or
column between occupied cells to make room for new data entry. Whenever you no longer
need the cell, row or column you can remove them from a worksheet, so that MS-Excel will
shift other cells, rows or columns to the left or up ward to fill the space occupied by the
deleted cell, rows or columns.

= To insert cells:
¢ Select the cell or range of cells the same size as the range of the cell you want to
insert.
¢ Choose Cells from the Insert menu or short cut menu.
¢ From the Insert dialog box, select the desired options.
¢ Click Ok.
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= To insert a row or column:
¢ Select the same number of rows or columns, as you want to insert.
¢ Choose Insert, Rows, or Insert, Columns to insert rows and columns respectively.
The new row will be inserted at the top of the selected row and the new column is
inserted to the left of the selected columns.

= To delete a row or column:
¢ Select the row or columns you want to remove.

¢ Choose Edit, Delete, or right click on the selected rows or columns and choose Delete

command from the shortcut menu.
5.4 Adjusting Row Height or Column Width

In some cases, you may want to increase or decrease the row height or column width to
change the look or appearance of the table structure and to fix row height or column width to

fit the specific size.

» To change row height and column width:

¢ Point to the jointry of rows heading or column heading. The pointer will be changed to
double headed arrow.

¢ Drag the mouse vertically to change the row height, or horizontally to change column
width.
OR

¢ Select the rows or columns you want to change their height or width.

¢ Choose Format, Row, Height, to change row height or choose Format, Column,
and Width, to change column width.

¢ From the dialog box, Enter a figure in points.

¢ Click Ok.
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6. Formatting a Worksheet

Formatting is adding several attributes that make a worksheet data appearance more attractive
and easier to read. Worksheet formatting includes changing the font type, font size, font color,
font style, applying and removing number formatting, changing alignment, boarders and

shadings, etc. You can format a work sheet cell before or after you enter data.

To format a worksheet cell and its contents, you can use the Formatting toolbar or the Cells

command from the Format menu.

6.1 Changing Font, Font Size, and Other Attributes

When you type or enter new data into a cell, MS-Excel automatically identify the data as text,
number, date or time data type. Usually texts are aligned left, while number, date and time are

aligned right.

» To format a worksheet cell:
¢ Select the cell or range of cells you want to format.
Click Cells from the Format menu.

Click on the tab from which you want to choose from the Format Cells dialog box.

* & o

Select the format type you want to apply.
¢ Click Ok.

» To format text in a cell:
¢ Select the text with in a cell.
¢ Click Cells from the Format menu.
¢ Select the Font type, Font size, Font color, and other text effects as you want.
¢ Click on Ok.
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» To apply built in number format:
¢ Select the cell range that contains numeric data.
¢ Click Cells from the Format menu.
¢ Click on the Number format.
¢ Click on the Category you want.
¢ Click Ok.
» To center a cells content across selected blank cells:
¢ Select the cell containing the data and extend the selection to the right.

¢ Click on Merge and Center icon from the standard toolbar.

» To wrap text in a cell:
¢ Select the cell.
¢ Choose Format, Cells.
¢ Click on Alignment tab.
¢ Click on Wrap text check box, to check if it is unchecked.
¢ Click Ok.

» To boarder a cell or range of cells:
¢ Select the cell or range of cells.
¢ Click on Boarders button on the Formatting toolbar.
OR
¢ Choose Format, Cells and Click on Boarders tab.
¢ From the Format Cells dialog box, select the line style, and line color you want to
apply.
¢ Select the boarder style and click Ok.
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6.2 Using Automatic Worksheet Formatting

Microsoft Excel has a redesigned table formats that contain different formatting styles, so that

you can use AutoFormat command to apply ready-made designs.

» To apply Automatic table format:
¢ Select the cell range you want to format.
¢ Click AutoFormat from the Format menu.
¢ Select the table Format type you want to apply.
¢ Click on Ok.

6.3 Conditional Formatting

You can apply different types of formats in a range of cells when specified conditions are
satisfied.

» To apply conditional formatting:

¢ Select the range in which you want to apply conditional formatting.

*

Click Conditional Formatting from the Format menu.

Specify the first condition, and click on Format button to apply available formats.
Click Add >> button, and specify other conditions if you have and format.

Click Ok.

* & o

Prepared by:
Tewelgn Kebede
16



SNMNPR Capacity Building Bureau

7.Using Formula and Functions

One of the most important worksheet entries is a formula. Unlike a text and a number data
type, a formula is entered in a cell to produce other entries, from the existing entries. Such
entries, which are the result of calculation, are known as calculated value. Use a formula
when you want to enter calculated value on a work sheet. Usually, you place a formula in a
cell where you want to see the results. When you select a cell that contains a formula, the

formula is always displayed in the formula bar

A formula is an expression consisting of:
¢  Theequal sign (=) at the beginning and bracket ( ).
¢  Constants, numbers, and references.
¢  Arithmetic operators (+, -, *, /).
¢  Functions like Sum, Average, Max
Example: = Average (A2:E2).
= Basic salary — Basic salary* Tax rate.
As illustrated above, a formula always begins with an equal sign (=) and followed by a function
name or sequence of characters to calculate values in a specific order. To easily work with MS-

Excel formula you should understand some of the basic element of formula.

7.1 Components of a Formula

1. Operators: an operator is a sign or a symbol that specifies the type of calculation. In MS-
Excel, operators are classified as:
a. Arithmetic operators (+, -, *, /).
b. Comparison operators (=, >, >=, <, <=, <>)
Logical operators like IF, AND, OR, etc

Q

Text operator like Concatenate and

e. Reference operators.
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Reference operators: references are actual cell addresses in a worksheet. Cell references are
three in type. They are: Relative, Absolute and Mixed references. The three basic
reference operators are:

" :(Colon): Range operator, reference all cells between and including the two
references specified, and produces one reference. Example A2:A6 means A2, A3,
A4, A5, and A6

" , (Comma): union operator combines multiple non-adjacent references. Example
Sum (D2:D4, E3, E6)

" Single space: An intersection operator that produces one reference from the cell or
ranges that have reference in common. Example (B1:B8, A2:E2), means B2.

Relative References: if you want the cell references in the formula to change when the
formula is copied to other cell, you use relative references of cell in the formula. This
reference type refers cell addresses that change dynamically relative to its position in a
worksheet. This allows you to use the same formula to calculate other sets of values in other
cells. Its format looks like B3: C4, A5, D255.
Absolute cell reference: are used when you want to fix the addresses of the cells to be
mutilated. Absolute reference is a reference type that tells MS-Excel how to find a cell based
on the exact location of that cell in a worksheet. It always points to that cell argument
whatever you copy the formula in a worksheet. To use a cell reference as an absolute
reference, we add a dollar sign ($) to the letter and the number references of the cell like
$B$2.
Mixed Reference: is also called hybrid reference. In case of mixed reference, either you have
to make the row number relative and the column letter absolute or vice versa.
Example: $AL: the column is fixed at A, and rows can be varied.

B$3: the column is varied while the row is fixed at row 3.
Note: To change the cell reference between Absolute, Relative, and Mixed reference types,
you can follow the traditional way of editing the formula using the keyboard. But the simplest
way is selecting the cell and pressing F4 function key repeatedly, until you get the desired

reference.
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2. Constant Values: Constants can be numeric values; a text value, date or a time value
whose values is fixed in a worksheet cell and your formula uses them to perform some
sort operations. Example, the number 21, the date 29-16-1995, and the text con are some
of the constant values.

3. Worksheet Functions: a worksheet function is a prewritten or predefined formula that

you can get in MS-Excel to perform calculations. Examples of worksheet
functions are SUM (), AVERAGE (), IF (), etc.

7.2 Excel Built-in Functions

Functions are ready made formulas, which are used to calculate specific quantities like Sum,
Average, Rank, Grade, etc. A function makes formulas to be compact, easy to use and
understand by removing complexity and redundancy or references. There is a specific way of
writing a specific function. The rule that you follow to write a function correctly is called the

syntax of the function.

In general, a function begins with a function name followed by an opening parenthesis,
arguments for the function (separated by a comma) and a closing parenthesis. Worksheet
functions are categorized into various groups for easy access (Fig. A below). From these,
some of the most commonly categories are:

1. Statistical: Performs statistical works such as Min, Max, Average, Product, and Mean.

2. Logical: are used to perform logical test. Examples are If, NOT, AND, and OR.

3. Math and Trig: are used to work on Mathematical and Trigonometry like Sum, Sine,

Cosine, Radian etc.
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4. Date and Time: Originates the date and time function.

5. Database: contains all the D-Functions (database functions as DSum, Daverage).

Paste Function @g|

Function category: Function name:
Most Recenthy Used EL N - |
all J FALSE
A. Financial IF
Date & Time MOT
Math & Trig QR
Skatistical TRLE
Lookup & Reference
Database
Texk
Information J J

AND(logicall logicalz,...)

Returns TRUE if all its arguments are TRUE; returns FALSE iF any argument: is
FALSE.

Ok | Cancel |

IF

Logical_test [B4 =90

Value_jf_true |".|:-."

Yalue_if_False ||

evaluates ko FALSE,

returned,

@ Formula result =FALSE

| = FALSE
E =
= FALSE

Returns one value if a condition vou specify evaluates to TRUE and anaother walue if it

¥alue_if_False is the value that is returned if Logical_tesk is FALSE, IF omitted, FALSE is

o]

Cancel

Fig. A. Function category.

B. Formula Palate of If function.

6. Text: Manipulates text.

Examples: Char: returns the character specified by the code number.

Lower and upper: returns text into lower and upper case respectively.

7. Financial: allows you to calculate loans; cash flow, payment, future
8. Lookup and Reference:

9. Information:

value, etc.
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7.3  Guided Formula Writing

If you do not know how to write the syntax of a function correctly, use the Formula Palate.

The formula palate is a tool that helps you to create or edit formula and also provides
information about the function and its arguments, and shows the result of the function or the
formula before the palate is closed.

»  To use the formula palate:
¢ Click Paste Function from the Standard toolbar, or
¢ Click Paste Function, from the Insert menu.
¢ Select the function group from the Category Name.
¢ Click on the function you want to use from the Function Name box.
¢ Click Ok (See Fig. A and B above).

7.4 Formula Error

When you enter a formula in a cell and press the Enter key or click another cell, either the
result of the calculation or an error message is displayed. An error message is displayed if
something is wrong either in the formula it self or in the values referred by the formula. To
create a valid formula, you must follow the syntax. If you don’t follow the syntax, MS-Excel
displays one of the following messages to indicate that there is a syntax error either in the

formula or function.

#Div/0!: An error message that indicates a number is divided by 0.

#N/A!: Error values occur when a value is not available to a function or formula.

#Name?: Microsoft Excel does not recognize a name used in the formula.

#Null!: error value occurs when you specify an intersection of two areas that do not
intersect.

#Num!: error value occurs when there is a problem in number.

#REF!: occurs when a cell reference is not valid.
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#Value: occurs when an argument or operand is of the wrong type.

8.Charts

A chart is a pictorial (graphical) representation or illustration of numerical data in a
worksheet. Charts show you what is difficult to see from several columns or rows of
numbers. Excel helps you create charts in two or three dimensions based on data in a
worksheet. A chart is linked dynamically to the worksheet so that any changes you make to
the worksheet data will automatically be reflected in the chart.

In general, charts show the tendency of a quantity to decrease (or increase) with time or
other factors. Several chart types and subtypes, each suitable for certain applications are
available in Excel. Some of them are the Column Chart, Pie Chart, the Area Chart, the Line
Chart, etc.

8.1 Components of a Chart

A chart has a number of elements, which can be selected, formatted and modified

independently of other components. Some of them are:

= Chart Area: is the entire area of the chart that includes all elements of the chart.

= Axis: are reference lines denoting the dimensions of a chart. There are three axes: X, Y,
and Z.

= Chart Title or Axis Title: is the title of the chart that describes data or object in a chart.

= Data Series: a group of related data points plotted in a chart that originates from rows or
colons on a single worksheet. Each data series in a chart has a unique color or pattern.
You can plot one or more data series in a chart. Pie charts have only one data series.

= Category Names: usually corresponds to worksheet labels for the data being plotted along
the X-axis (horizontally along the chart).
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= Data Markers: Are bars, pie wedges, dots, pictures, or other elements, used to represent a
particular data point (a single value in a series). When charts have more than one data

series, the markers for each series usually look different.

= Gridlines: are vertical, horizontal or diagonal lines that extend from the axes to the plot
area to make the chart easier to read the data.

= Legend: is a box that identifies the patterns or colors assigned to the data series or
categories in a chart and displays the data series name that corresponds to each data
marker.

= Data Table: is a grid in a chart that contains the numeric data used to create the chart.
Each row in the data table represents a data series.

= Data Series Names: usually corresponds to chart labels for the data being plotted on the
Y-axis.

= Chart Text: the chart wizard automatically adds text things like chart and data labels. It is

possible to add text boxes containing notes.
8.2 Creating Charts.

A chart can be created on a sheet (chart sheet) or on the worksheet containing the data
(embedded chart). In any of the two cases, the chart is updated automatically whenever any of
the values or any thing in the source data changes. This is because the chart is linked to the

data. MS-Excel provides you the following two tools to create a chart.

The Chart Wizard.
The Chart toolbar.

i. Creating a chart using the Chart Wizard: this method is the easiest and most

suitable way of creating charts.

» To create a chart using the chart Wizard:
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¢ Select the range of cells in a worksheet that contains the data you want to plot. When

you select the cell range, be sure whether you select the row or column labels
of a numeric data you want to display in the chart.

¢ Click Chart from the Insert menu or standard toolbar.

¢ The dialog box will appear as shown in the Fig. Below.

¢ Follow the Wizard to complete the chart.

Chart Wizard - 5tep 1 of 4 - Chart Type

Standard Types | Cuskom Types ]

Chart bype: Chart sub-type;

.+ K (Scatker)

‘ Area
@ Doughnut |

o

il
i

@r Radar
@ Surface a

&+ Bubble

[ﬁ;ﬁ_ Skack j

Clustered Column, Compares values across
categaties,

Press and Hald ko Wiew Sample |

Cancel | Mext = | Finish |

Once you create a chart you can print, hide spell check modify or even include in your non-
Excel documents like Word or Power point.
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8.3 Selecting, Resizing, Moving and Deleting Chart

Once a chart is created, it is possible edit and format at any time. To do this, you must select
the chart either independently or in a group. When you select a chart item, MS-Excel will
automatically mark it by displaying the resizing handles (or black squares) at the corner and

side of the selected item boarders.

» To select a chart item:
¢ Click on the item.
» To select a chart:

¢ Click on the chart area (wall of the chart).

If a chart is on a separate sheet, you cannot move or resize it, but if it is embedded in the
data sheet, you can resize it and move some of the items like the plot area, the legend, and
the chart itself using the sizing handles.

» To resize a chart or chart item:
¢ Select the chart or chart item. A rectangle with square marks will surround the item.
¢ Point to a sizing handle (the mouse pointer changed to a double-headed arrow).

¢ Click and drag, until the chart item is the size you want.

> To move a chart or chart item:
¢ Select the entire chart to move a chart or chart item to the chart item.
¢ Point to it. The mouse pointer changes to an arrow.

¢ Drag the chart anywhere in the worksheet or drag the chart item with in the chart

area.
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» To delete a chart:
¢ Click on the chart area to select the chart.

¢ Press the Delete key or click on Clear from the shortcut menu.

8.4 Editing and Formatting a Chart

You can change items like the chart type, the range of the source data, the data series, the
scale used on the value axis, the order of the data series in case of more than one data series,
the pattern, the color, or in general, the appearance of chart items could be changed. More

over, legend, data labels, and values could be displayed on or removed from the chart.

A chart or any of its components could be formatted or edited. This is done by selecting the
component (chart) to be formatted and choosing the appropriate command from the Chart
command or from the Format menu. But the easiest way is to right click the chart or the

chart item and choose the appropriate commands from the short cut menu.

Though you can add chart title (subtitle), axis titles, legends, etc, during the process of

creating the chart, it is also possible to add those items after the chart is created.

» To format the chart component:
¢ Select the item.
¢ Double-click the item to display a formatting box (color, font, size).
¢ Format the item using the necessary formatting tools.

Click outside the chart.

*

> To format the chart walls:

Click the chart walls.

*

Choose Selected plot area from the Format menu.
Choose Fill Effect.
If necessary, select the Gradient tab.

Select Preset in the colors section.

® & & oo o

Click the down ward arrow beside the preset color box and choose from the list.
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¢ Click Ok.

9. Lists and List Operations

The data in an MS-Excel worksheet is often referred to as a list. A list is simply a series of
rows that contain similar data sets and that are topped by a row of identifying labels. The
advantage of lists is that you can manipulate them to suit your needs like searching for data
that meets specific conditions, filtering out other data that you don’t need at to see at the

moment, arranging the list by the last name, etc.

Lists are often referred to as databases. A database is a collection of related information
about a particular subject, which is used to organize, manage and retrieve data in rows and
columns. With in a database, information about a particular entity such as an employee or
order is categorized into tables, records and fields.

Whenever you want to work with a Microsoft-Excel database, you should identify and
understand the following basic terminologies.

Database Range: is a rectangular range of worksheet cells defined as a database.
Record: is a single row or rows of data in a database that contains complete
information about an entity.
Field: is a single column in a database that contains pieces of information about an
entity in a database.
Field Name: is a name hat identifies the data stored in a field.

For example, the fields in a personnel list might include Name, Father Name, Id NO,
Department, Salary, and Employment date. Typically each record is one row of data and

each field is one column of data. The column headings are called field names.
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9.1 Adding and Modifying Data

You can add new records, delete existing data, modify existing data, and perform searching

using the Form command from Data menu.

» To add new records using a data form:
¢ Click a cell in the list you want to add the record to.
¢ Select Form from the Data menu. The Form dialog box having the title of your

worksheet will be displayed as shown in the fig. Below.

Male: || ﬂ Mew Recard
Femnale : Mews

Takal:

Find Prew
Find Mext

Criteria

gL

Close

¢ Enter field values in their appropriate text boxes.

¢ To move to the next field, press TAB key. To move to the previous field, press
SHIFT+TAB.

¢ Click on New button to add a new record. The data form field text boxes are created
to allow you enter another new record.

¢ When you finish click on Close button.
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» To modify or edit data with a data form:

¢ Open the data from dialog box.

¢

¢

Use the scroll bar or Find prev and Find Next button to view the record you want to
modify or edit.
Click Close.

> To delete a record:

¢

¢

¢

From the Data menu, Click Form.
Find the record you want to delete.
Click delete button, and choose Ok and then Close.

» To find a record:

*

*

*

L 4

L 4

Open the data from dialog box.
Click on the Criteria button.
Specify the criteria in the text box.
Search a matching record.

Click close.

9.2 Sorting a List

Sorting is rearranging a given list in the desired order (either in ascending or descending)

depending on the contents of a column or row.
» To sort data by field:

¢

¢

¢

Select the list you want to sort.

Click Sort from the Data menu.

In the Sort By drop-down list, select the sort field and sort order (Ascending or
Descending).

To sort by more than one field, click on the Then by drop-wown box to specify the
second and third level sort key and their corresponding sort order.

Click Ok.
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9.3 Subtotal

Subtotal is used to perform analysis on a data, which is sorted by a broad field like: sex,

country, and city.

> To use subtotal:

¢ Click inside the list.
Sort the list by a field.
Click Data, Subtotal.

Select the sorting field in the At each change in box.

*® & o o

Select a function from the Use Function box and click Ok.
» To remove subtotal:
¢ Click Subtotal from Data menu.

¢ Click Remove All button.

9.4 Filtering

Filtering is the process by which some part of a database is displayed satisfying a given
criterion. Excel provides you with various ways of filtering a list. Some or these are:
1. AutoFilter

2. Custom Filter
3. Advanced Filter

1. Auto Filter: gives you the possibility to choose one of the values in a field in order to

display all the records with the selected value in the field.
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> To use Auto Filter:

¢

¢
¢
¢
¢

Note:

Click in side the list (Select the list).

Choose Data menu, Filter and then Auto Filter.

A down-pointing arrow appears to the right of each field name.

Click on the downward arrow of the criteria field and select a Condition or Custom.

Specify the condition.

1.After an auto filter session, to display all the data, Click Data, Filter, Show
All.

2. To cancel auto filter, repeat step 2 above.

3. Custom Filter: allow you to specify you own criteria to select records. It allows you to

create a criteria (simple or compound) by choosing the comparison operators like is

equal to or is greater than and values from the boxes on the Custom dialog box. To

create a compound criteria such as salary is less (greater) than birr, you have to use

one of the logical operators (and, or) between the two operator boxes.

» To apply custom filter:

¢

¢

¢

Click a cell in the list (select).

Choose the Filter command from the Data menu.

Choose the Auto Filter command, and click the arrow next to the column on which
you want to set criteria.

Choose Custom and fill in the custom dialog box.

Click Ok to apply filtering.
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3. Advanced Filter: allows you to create multiple criteria on list records.
» To use advanced filter:
¢ Create a Criteria range (is created by copying the fields (hame, sex, mark, etc) on
an empty range of cells).
¢ Click inside the database.
¢ From the Data menu, choose Filter, and the Advanced Filter.
¢ Select the list range.
¢ Select the criteria range.
¢ Choose whether to see the result in place or another location.
¢ If you choose another location, click on the empty cell where you want to see the

result.

Note: If the criteria are joined by AND, type the criteria in the same row and type

each criteria in different rows if the criteria are joined by OR.
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10. Printing

10.1 Page Setup

Using the page setup command from the File menu, you can change the page range, page

orientation, scaling, the margins, Header and footer, etc.

» Toset up a page:

¢ On the File menu, click Page setup.

¢ Click the Page tab to specify page orientation (Portrait, or Landscape), Scaling,
and Paper size.

¢ Click Margins tab to specify spaces from top, bottom, left and right.

¢ Click Header and Footer tab to add or remove header and footer.

¢ Click the Sheet tab to specify print area, Print title, to add or remove gridlines, and
page order.

¢ Click Ok.

10.2 Previewing Print outs.

The print Preview window lets you see how the sheet or print area will look when you
actually print it. There fore; to save wastage of paper, toner, and to increase the appearance

of the print page, click on the Print Preview button from the File menu or standard toolbar.

In this window, the Status bar shows the current page number and the total number of pages
in the active window so that you can easily change or adjust the set up of the page and its

appearance and you can go through each page in the selected worksheet.
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> To Preview Print outs:

¢

¢

Click Print Preview from the File menu or standard toolbar.

From the Print Preview toolbar, click:

o
*

*

o
*

*

>

L)

Next: to display the next page of the sheet.

Previous: to display the previous page of the sheet.

Zoom: to switch between full-page view and magnified view.

Print: to set printing options.

Setup: to display the page setup dialog box.

Margins: to display or hide margin handles.

Page break Preview and Normal view: to switch between the page break
preview and the normal view respectively. Page break preview lets you adjust
the page position easily to resize the print area. A Page break is a separator of
the worksheet into pages.

Close: to close the Print Preview window.

10.3 Printing All or Part of a Worksheet

Once you have previewed your worksheet to check that everything is just right, you can go a

head and print. By default, Excel prints the active worksheet, but you can print the entire

workbook or just a selected range of cells. In addition you can decide how many copies to

print and which pages to print, in case you don’t need to print all pages in a worksheet.

> To print all or part of a worksheet data:

¢

¢

¢

Click print from the File menu.

Under Name box, select the printer name you use.

Under Print Range, select All to Print all pages or specify the page range in the

Page(s) From option.

Under Print What, select the option you want.

Under the Copies, specify the number of copies.

Click Ok.
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10.4 Printing Charts

When a chart is created as an object on a worksheet, you can print it separately, or you can

print both the chart and the worksheet together on a page.

» To print a chart:

¢

¢

¢

Select the chart.

Select File, Page Setup.

Click the chart tab, in the Page setup dialog box.

Select one of the three option buttons in the Printed Chart Size option group.

v Use full Page: to stretch the chart over the full length and width of the page.

v' Scale to fit page: to fill as much of the printed page as possible, while
maintaining the height to width ratio that you have established in the chart.

v Custom: Prints the chart in the same size as the chart you have produced.
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