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1. Introduction                          

 

1.1 What is Word Processor? 

 

If you want to write words, memos, reports, newsletters, handouts, magazines, etc on a computer 

you need a Word processor.  

Some of the main advantages of word processor over the conventional type writer is its ability to 

enable you:  

 Correct spelling and grammar error. 

 Format and edit your documents as you wish. 

 Enter symbols, pictures, tables and data from other sources. 

 See and adjust the print preview of your document that avoids wastage of resource.  

 Make changes to an already written document with out retyping the entire document. 

 

Word processor can be divided into two groups: Text editor and full-featured. A text editor 

supports only the following features: editing tools, word wrap facility, printing tool and page 

setup tools. Full-featured word processors include more tool and facilities than text editors do. 

 

There are a number of word processing packages. Among these are Word Perfect, Word star, 

AmiPro, and Microsoft Word. Microsoft Word is the most popular word processor.    

 

Microsoft Word (MS-Word) is full-featured word processing software that runs on the windows 

operating system, which enables you to create, edit, format, print and save documents (text file) 

for future retrieval and revision. When you create any type of document in MS-Word you can 

extensively use the MS-Word editing and formatting tools to make your document attractive, 

meaningful, and visual. 

 

MS-Word lets you combine text that have been formatted in a variety of styles with graphics and 

can include table and the data from other software’s such as MS-Excel, MS-Access, MS-

PowerPoint, etc. pictures can be inserted any where in a page in different sizes. 
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MS-Word has gone a number of versions, with the latest being MS-Word 2000. The previous 

versions or releases were word 2, word 6, word 95, and word 97. All the basic ideas and 

principles of the versions remains the same and one of the basic skills on how to use MS-Word 

2000 can use any of the versions of Word. This training manual is prepared with MS-Word 2000 

in mind. 

 

In addition to text editor, discussed above, MS-Word 2000 includes the following features: Font 

specification, grammar and thesaurus, graphics, Mail merge, auto text format and styles, wizards 

and templates, and help facility.  

 

1.2. Starting Microsoft -Word  

   

Before you think of starting MS-Word 2000, you first turn on your computer to start Microsoft 

Windows XP. Once you start windows, follow the following steps to start MS-Word. 

 To start MS-Word 2000 from the Start button: 

 Click Start. 

 Point to All Programs. 

 Click Microsoft-Word. 

 To Start MS-Word using the shortcut: 

 Double-click MS-Word from the Desktop if there is. 

      Or 

 On the Microsoft Office short cut bar, click the MS-Word icon. 

      Or 

 Click Microsoft-Word form the Start menu. 

 

Screen Elements of MS-Word 

 

Immediately after starting MS-word, you will be provided with two nested windows (a window 

with in a window). The outer one is the application (Program) window named Microsoft-Word, 

and the inner one is a blank document, just like a white paper to write on, named Document 1. It 

allows you to communicate with the word program to use the Word facilities efficiently and 

easily.  
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 Title bar: is used to display the application and document name you are working with and 

control menu, Minimize, Restore & Close buttons. 

 Menu bar: The bar located just below the title bar with series of menu names. Each menu 

contains related commands. 

 Standard Toolbar: Provides quick access to most frequently used commands and utilities. It 

contains icons, combo boxes and other controls.  

 Formatting Toolbar: This contains icons, buttons, combo boxes, etc for changing the look of 

your text called formatting. 
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 Status bar: Also called status area that is found at the bottom of the Microsoft- Word 

application window. This bar gives the following information.

 Current page 

 Section number 

 Current cursor position 

 Current line number 

 Record macro 

 Over Type mode 

 Current/Total pages in a document 

 Current column number 

 

 To display or hide the status bar: 

o Click Options from Tools menu. 

o Click View tab 

o Check or uncheck the check box of Status bar to display or hide respectively. 

 

  View Buttons: Are series of buttons in the lower left corner of the document window. These 

buttons are Normal, Web Layout, Print Layout, and Outline View. They are used to change 

the way your document is displayed on the screen. By default, Word uses Normal view. 

 Select Browse Button: Located in the lower-right corner of the document window, lets you 

quickly jump from one part of your document to another by page, table, graphics, etc. 

 Ruler: used to measure page width, height, margins, tabs, indents, etc. 

 Insertion pointer: Is a blinking vertical bar to indicate where the character you type will 

appear. 

 Typing area: is the blank area for text entry. 

 

1.3 Arranging Screen Elements of MS-Word 

   

Microsoft-Word screen element includes tool bars, status bar, rulers, scrolling bars, etc. 

Arranging and customizing some of these elements is important whenever you work with Ms-

Word. You can also display or hide screen elements at any time whenever you think that is 

important. 

To display or hide tool bars: 

 Click View from the menu bar. 

 Point to Tool bar.  

 Click on the tool bar name you want to display or hide.  
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Note: 

 A check mark to the left of a tool bar name, displays the tool bar while if it is unchecked, 

the tool bar is hidden. 

 To change the position of the tool bars, you can drag and drop the desired tool bar to the 

desired place.  

 

 To display or Hide scroll bar/arrows and vertical ruler: 

 Click on Tools. 

 Click Options. 

 Click on View tab. 

 Clear or unclear the check mark from the check box to hide or to display the desired bars 

respectively. 

 Click Ok.  

 

1.4 Creating a Document   

 

You can create a new document in three ways: 

 Using Wizard: which gives you a step-by-step help to create the document. 

 Using Template: which sets up the structure and formatting of the document. 

 Using Blank Document: starting creating the document from scratch. 

   

Creating Documents Using Wizards 

 

Word provides wizard for creating legal pleadings, words and faxes, memos, publications, 

reports, web pages, and other common type of documents. 

 

 To create a document using Wizard: 

o Click New from File menu. 

o From the New dialog box, Click on any of the tabs that you want to create. 

o Click Ok. 
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Creating a Document Using Templates 

 

A template sets up the structure and formatting (font, font style, font size, margins, etc) for all 

documents of certain type such as words, memos, or reports. You use a template when you do not 

want to spend time answering the questions posed by a wizard. 

 

 To create a document using templates: 

o Click New from File menu. 

o On the New dialog box, click on any tab of interest. 

o Select from among the icons, as you prefer. 

o Select Template option button. 

o Click Ok. 

 

Creating a Document from Scratch 

 

When you start MS-Word, a new blank document called “Document 1” appears. If you want to 

create a new document at any time, perform the following procedure. 

 From File menu, click New. 

 Click General tab. 

 Click on the Bland Document icon. 

 Click Ok. 

 

Or 

 Click New icon from the Standard Toolbar. 

             
The blinking vertical line segment at the beginning of the first line on the blank document is 

known as insertion point or cursor. The cursor shows you where the text you type is going to be 

inserted. To create a document, simply type on the keyboard. 
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Basics of Entering Text. 

 

A new document window always provides you with a blank text area in which you can type your 

desired text. Word automatically provides a whole set of critical document settings (default 

values) including margins, font, font size, line spacing, page dimension, and many other 

document attributes. You can therefore, start to type immediately with out first having to specify 

any of the settings your self. 

 

 To enter text into a document: 

o Place the insertion pointer where you want to insert the new text. 

o Simply type the new text. 

You can enter or insert text while you are in Insert Mode or Over Type mode. If you are in: 

 Insert mode: MS-Word pushes the newly entered text to the right of the insertion pointer 

farther to the right. 

 Over Type mode: MS-Word over types or replaces the existing text by the newly entered 

text character. 

 To switch between Insert and Over Type mode: 

o Press Insert key from the keyboard, or 

o Double-click on “OVR” button from the Status Bar. 

 

When typing in a document, you need to enter spaces of various dimensions to make the 

document readable. The keys Enter, Tab, and Spacebar are all used to create spaces of various 

dimensions.  

 

The Spacebar: is used to create a space between words. 

The Tab key: also creates a space but of a larger dimension, depending on the settings defined 

by you or setting of Word. Press tab key to indent the first line of a paragraph. 

The Enter key: In Word, when a text does not fit at the end of a line, it automatically flows to 

the beginning of the next line. This feature is called Word-wrap. However you have to press the 

enter key in order to: 

 End a short line (one that does not reach the right margin). 

 End of a paragraph. 

 Create a blank line. 
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Caps Lock key: is pressed to produce all upper case words and press it again to switch off this 

feature. 

Shift key: hold-down this key to produce a single upper case word while pressing a key and to 

type those characters found at the upper half of a key. It is also used in combination with other 

keys to perform different tasks. 

Backspace key: deletes characters to the left of the cursor. Press this key if you accidentally 

press Enter, Tab or Backspace keys. 

Delete key: deletes characters to the right of the insertion point. 

 

1.5 Moving around a Word Document 

 

You can use a keyboard or mouse to position the insertion pointer anywhere in a document.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Though you cannot move the insertion pointer using a scroll bar, it is a best way to use a scroll 

bar to scroll through a long document easily. 

 

The simplest way to move the insertion pointer in a document is positioning the mouse pointer to 

a desired location and click. In addition to a mouse, you can also use the following keyboard 

options to quickly move around a document. 

 

Press Action 

Up/down arrow keys To move the cursor one line up/down. 

Left/Right arrow keys To move the cursor one character to the left or right. 

Ctrl + Left/Right arrow To move the cursor one word in the arrow direction. 

End To move the cursor at the end of the line. 

Home To move the cursor at the beginning of the line. 

Ctrl + End To move the cursor at the end of the document. 

Ctrl + Home To move the cursor at the beginning of a document. 

Page up/Page down To move one screen up/down. 

Ctrl + Alt + Page down To move the cursor to the top of the next page. 

Ctrl + Alt + page up To move the cursor to the bottom of the previous page. 
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1.6 Saving Documents 

 

When you create a new document, or make changes to an existing document, what you have 

written or modified exists only in the computer memory (RAM), a temporary storage area. For 

permanent storage, you must tell the computer to write it on a secondary (auxiliary) storage 

device for latter use. The process of writing data in memory to a disk in the form of a file is 

called saving. Word provides two commands you can use to save your documents: Save As and 

Save. 

 

Save As Command 

 

You use the Save As command to save a document for: 

 The first time. 

 To save a document with a new name,  or 

 To save a document on a different location (on another disk or folder). 

 

 To save a document using Save As: 

 Click Save As from File menu to open Save As dialog box. 

 In the Save in box, select the folder or drive in which you want to save. 

 In the File name text box, type the name for the document. 

 Click Save button to confirm. 

 

Note: Word automatically assigns the extension .DOC to all word documents and the  

            title bar displays immediately the newly assigned file name as soon as you  

            click on Save. 

 

Save Command 

 

You use the save command to save a document with its current name and in its current location 

which is on your screen. It updates a saved document with the new version of the document. If 

you click on the save command for files which are not saved for the first time, the Save As dialog 

box appears. 
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Automatic Saving 

 

Word provides an automatic save option. When this option is on, Word automatically saves all 

your active documents at a specified time interval. 

 

 To save a document automatically: 

i. Choose Options from Tools menu. 

ii. Click on the Save tab. 

iii. Click on Save Auto Recovery info every check box; if it is unchecked and set the 

minutes of auto save, as you need. 

iv. Click Ok. 

 

1.7 Exiting Word 

 

The final step of every Word session is to exit Word. Never turn off your computer before doing 

so, as this could result in the loss of documents. 

 To exit Word:  

 From the File menu, Click Exit, or click on the applications Close (X) button. 

Note: If you have not saved the latest versions of an active document, Word will prompt you to 

do so before exiting by showing the following dialog box. 

 

 

 

 

 

 

If you want to save the changes, choose Yes, if you don’t want to save, choose No, if you change 

your mind about exiting, choose Cancel. 
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1.8 Opening a Document 

 

The benefit of saving a document on a disk is that you can latter open (re display) it for use, 

revise, or reprint. The act of accessing (reading or retrieving) the document you have stored in 

some disk storage is known as Opening. 

 To open a file: 

 Click on the Open button in the standard toolbar, or choose Open from the File menu. 

 In the Look in text box, click on the drive or folder where your file is stored. 

 Double click the name of your file.  

 

1.9 Using Word’s Help Facility 

 

Word’s Help facility provides you with all the information that you need, on how to do things in 

word processing.  

 

 To get help using the Help menu: 

 Click Help, and then Microsoft Word Help,  

 OR press F1 from the keyboard. The Help window is displayed if the Use Assistance 

Option is turned off. There are three tabs in the Help window: 

I. Contents tab: to view Help’s table of contents. 

II. Answer Wizard tab: to type a question to an office program. 

III. Index tab: to search for specific words or phrases. 

 To get help using the office Assistant. The office assistance is an animated help system that 

can assist you by actively inspecting how you are working with MS-Word. Clicking the 

Office Assistant displays the “What would you like?” dialog box which you can write any 

question about any feature or tool in MS-Word. If you satisfy with the topics listed, click on 

the topic to get help, or escape if you don’t satisfy. You can also use the light bulb to display 

tips. Tips provide information about performing a certain task more effectively. 

 

 The Shift + F1 combination. If you want a description on the functions of the window 

components of Word, use the Shift + F1 key combination, (or click Help, and then What’s 

This?). This will change the mouse pointer to an arrow and a question mark; then click on 

any of the items you want to know about. 
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2. Editing a Document 

 

Editing a document means modifying what you have typed to insert new item (text, drawing, 

pictures etc) to correct it, to remove unwanted item, to move or copy texts etc, to make a 

document readable. 

 

To do editing you have to scroll to see what is wrong and then move the cursor to that particular 

position. To scroll through a document, using the previous or next scroll buttons you have to 

choose the Select Browse Object first. There are various Browse objects. Some are: 

 By Page: allows you scroll from page to page. 

 By Graphics: lets you scroll from one graphic object to the next. 

 By Table: lets you scroll from one table to another. 

 By Section: lets you scroll from one section to another. 

 By Heading: Allow you to scroll from one heading to another. 

 

To change the browse object, click the Select Browse Object, and choose one. By default, 

browse object is by page. So if another browse object is not selected, the double arrow buttons () 

are used to scroll from page to page. Scrolling does not change the position of the insertion point, 

while moving does. 

 

2.1 AutoCorrect and AutoText 

 

The Auto Correct facility capitalizes the first word of a sentence, the name of the day’s months 

etc. It also corrects simple words like and, the, automatically, if misspelled. It corrects irregular 

capitalizations like two capital words at beginning of a word.  

 

 To set the Auto Correct facility: 

 Click Insert.  

 Click Auto Text, Auto Text. 

 Click the Auto Correct tab. 

 Click on the check box if it is unchecked.  
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The AutoText facility allows the user to store the word or the phrases that have to be typed in 

many documents. Such collection of words or phrases entered by the user is known as Custom 

dictionary.  

 

 To add a word to the custom dictionary: 

 Click the Auto Text from the Insert menu  

 Click Auto Text, Auto Text tab and type the word you want to store in the Enter Auto 

text entries here text box, click Ok to confirm.  

 

If there is a word in the Auto text vocabulary, whose four words are the same as the word you are 

typing, then the whole word or phrase will be displayed in the rectangular box after the fourth 

word to the right of the insertion point. Press the Enter key to accept the completed word, or 

continue your typing to reject the offer. 

 

2.2 Automatic Spell Checker, Grammar Checker and Thesaurus  

 

Spell Checker: It underlines with red misspelled words, or words not available in its vocabulary 

and repeated word like but but, if the Check Spelling as you type option is set ON. To correct 

the spelling and to remove the red line, right click the underlined word and choose one of the 

suggested words if you satisfy or click Ignore All to reject the suggestion. 

 

You can also choose the Spelling and Grammar command from the standard tool bar or click 

Spelling and grammar from Tool menu to display the spelling dialog box. Select one of the 

suggested words, if available and choose Change to replace the wrongly spelled word by the 

correct one or click Ignore to remove the red line only. 

 

 To set the check spell as you type: 

 Click Tool, Options. 

 Click Spelling and Grammar. 

 Click Option from the dialog box.  

 Click on the Check Spelling as you type, if it is un checked.  
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Grammar Checker: If the Check Grammar as you type or Check Grammar with spelling is 

turned ON, grammatical error or error in the punctuations are underlined with green as you type. 

You can correct or ignore the error following the same procedure as in the spelling correction 

case. 

 To set ON the check grammar as you type: 

 Click Spelling and Grammar tab in Option from Tool menu  

 Choose the Check Grammar as you type if it is unchecked. 

Thesaurus: is a book containing words arranged in their meanings.  

 To use Thesaurus:  

 Select the word you want to change or find its meaning. 

 Choose Thesaurus from the language sub menu of tools. 

 Choose one of the suggested lists of synonyms, and click Replace if you want to take an 

alternative word. 

 

2.3 Selecting a Text 

Usually, the first step in editing a document is to identify the parts to be changed or modified. 

This is possible by selecting; highlighting or shading a certain amount of text for deleting, 

moving, copying, formatting, cutting and the like is known as Selecting .You can use your mouse 

to select a text by dragging, clicking or double-clicking. You can also use the keyboard or both 

the keyboard and the mouse altogether to select text. Clicking any where in the document 

deselects the selected text. 

To select: Do this. 

A word Double-click in the word. 

A graphic Click the graphic. 

A line Drag over the line beginning from the end or beginning, or move the pointer 

to the left of a line until it changes to a right-pointing arrow, and then click. 

Multiple lines Move the pointer to the left of a line until it changes to a right-pointing arrow, 

and drag it up or down. 

A paragraph Move the pointer to the left of a line until it changes to a right-pointing arrow, 

double-click in the paragraph. 

Multiple paragraphs Move the pointer to the left of a line until it changes to a right-pointing arrow, 

double-click in the paragraph and drag up or down. 

Entire document From Edit menu, choose Select All. 



MS-Word Training Manual 

Prepared by:                                                                                                    December 1998 E.C 

             Tewelgn Kebede    14 

 

 

2.4 Copying and Moving Text. 

 

Rearranging the order of paragraphs, changing the position of text (moving), duplicating text 

(copying), removing a text (deleting), in a document are common editing operations. You can 

copy or move text; or graphics with in a document itself, between two or more documents; or 

between two or more applications. 

Copying: is the process of making a copy of the selected text or graphics and insert (or paste) it 

into another location. While moving is the process of removing (cutting) the selected text or 

graphics from one location and inserting (or pasting) it into another location. 

 To move or copy text: 

 Select the text you want to move or copy. 

 From Edit menu or Standard toolbar choose Cut to move, or Copy to copy. 

 Place the insertion point where you want to put the cut or copy. 

 Click Paste from Edit menu, or Standard toolbar. 

 To delete a block of text: 

 Select the text to be deleted. 

 Pres Delete or Backspace key. 

 

2.5 Find and Replace 

 

There are times when you need to find, select and replace a word which have repetitive 

occurrences in a document. You can use the Find and Replace commands to search for text, 

formats and special characters such as page breaks, spaces, tabs, foot notes, section breaks, and 

line break and replace them by other items.  

 To find text in a document:  

 From Edit menu choose Find. 

 Type the text you want to find in the Find What text box. 

 Click on the Find Next button. Word highlights the first occurrence of the word, if any. 

 Continue clicking Find Next to look for more matches. 

 Click Ok to return to the Find and Replace dialog box. 

 Click Cancel to return to your document.  
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 To replace text automatically: 

 From Edit menu, Choose Replace. 

 Type the text you want to find in the Find What text box. 

 In the Replace text box, type the text that will replace the Find What text. 

 Click on Find Next button. Word highlights the first matching word if any.  

 To replace the word, click the Replace button. If you don’t want to replace this word 

click Find Next again until you get the next matching word. If you want to make the 

change through the whole document with out confirming each replacement, click on the 

Replace All button instead of Find Next.  

 

2.6 Using Undo and Redo Commands 

 

Ms- Word keeps track of editing or formatting attributes that you made to your document. If you 

make a mistake, you can probably undo it with the Word’s Undo command. Word lets you undo 

most recent actions, including typing, deleting, moving, copying and formatting text. However 

Word cannot undo certain actions such as opening, saving, or printing a document.If the Undo 

command didn’t produce the result you expected, you can use the Redo command to reverse the 

undo. 

 To undo or redo your most recent actions: 

 From Edit menu, Choose Undo or Redo, or click Undo/Redo button from the standard 

toolbar. 

Note: You can also click the drop-down combo box next to the Undo or Redo  

           commands on the standard toolbar to select series of actions or tasks you want  

           to undo or redo. 

 

2.7 Document Magnification 

 

Document magnification or zoom control is the way you enlarge or reduce the display of the 

active document. This will help you to zoom in (or enlarge) the appearance of the document 

content so that you can easily edit them if you have small objects or small size fonts in a 

document. On the other hand, you can zoom out (reduce or shrink) the document so that you can 

see multiple pages or more of the document content at once. This feature does not affect the way 

your document will print.  
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 To zoom in or zoom out document view: 

 Click on the View menu. 

 Choose Zoom command. 

 Under Zoom to, select the zoom type you want or specify it in percent ranging from 

10% to 500%. 

 Click on Ok. 

           OR 

 Click the Zoom drop-down combo box on the standard toolbar. 

 Click the zoom you want to apply. 

 

3. Formatting a Document  

 

Formatting refers to all the techniques that enhance the appearance of your document so that it 

becomes readable and attractive. Editing changes the content of a document, while formatting 

changes its appearance. 

 

To format a document we use the format menu on the menu bar or the buttons on the formatting 

toolbar. Selecting the text and clicking the buttons do formatting, and the formatting is removed 

by clicking the same button you have used to apply the formatting after selecting the text. 

In general, there are three types of formatting: Character formatting, Paragraph formatting, and 

Page formatting.  

 

3.1 Character Formatting 

 

Character formatting includes all the features that affect individual characters. You can apply 

formats to: 

 Change Font (Arial, Times New Roman, Tahoma, etc) of characters. 

 Font size (from 8pt-72pt) of text. 

 Font style (Bold, Italic, and Bold Italic) of Characters. 

 Apply formats such as Underline, Double underline, Strikethrough, etc. 

 Create Superscripted (as X
2
, 1

st
, 32

nd
) or Subscripted (as H2O, H2SO4) text. 

 Change space between characters such as Expanded or Compressed. 

 Apply different animation effects on characters. 
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Note: You can apply the above different formats to any amount of text, from a few  

           characters or paragraphs to an entire document. 

 To format characters using the standard toolbar: 

 Select the text you want to format. 

 Click on the Font you prefer from the drop-down font combo box. 

 Click on the font size you want from the Font Size combo box. 

 Click on the Font Style buttons (B, I, U) as you want. 

 

Using the Font Command from the Format menu. 

 

Use the Font command from the Format menu, to change several formats at once. You can also 

use this command to see what the selected text looks like before you apply the formatting 

attributes to the text. 

 

 To format characters using the standard toolbar: 

 Select the text you want to format. 

 Click Font from the Format menu. 

 Click the Font tab. 

 From the Font, Font style and Font size list boxes select the type of attribute you want. 

 To underline, click on the Underline drop-down list and click on the underline style you want. 

 To change the font color, click on the Color drop-down list and click on the color you want. 

 To apply the Effects (Superscript, Subscript, Small case, etc.) click on the desired check box. 

 Click Ok. 

 

Copying Character Formats 

 

If you have applied several different character formats, such as a font, font style, font size, etc, to 

a text in your document and you would like to apply the same formatting to another block of text, 

you will have to apply the same formatting. Instead you can use the Format Painter button from 

the Standard Toolbar to take all the formats from the original block of text and apply them 

across the new text. 
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 To copy character formats:  

 Select the text that has the formatting you want to copy. 

 Click on the Format Painter button in the Standard Toolbar. 

 Drag on the text to be formatted. 

 

Applying Animations 

 

Animation effects can be applied on characters or selected text to make your document more 

decorative and leave message for the user to take emphasis on it. 

 

 To apply animation:  

 Select the text you want to animate. 

 Choose Format, and then Font. 

 Click on Text Effects tab. 

 In the Animations box, click the effect you want to apply. 

 Click Ok. 

 

To remove an animated effect, select the text, and then click Font from Format menu, click Text 

Effects tab and click None in the Animations box.  

  

Changing Cases of Words 

 

While you are typing text you can change the capitalization of the text by pressing Caps Lock 

key from the keyboard or by using the Shift key in combination with other words from the 

keyboard. 

 

But once you type the text and wants to change the cases of text in a document, MS-Word 

provides the Change Case command. So that you can use this command to change the 

capitalization of the selected text to UPPER CASE, lower case, Title Case, and tOGGLE 

CASE. 
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 To change cases of words: 

 Select the text. 

 Chose Change Case from the Format menu. 

 Select the options you want. 

 Click Ok. 

 

Drop Cap Command 

 

Use the Drop Cap command from the Format menu to create large initial capitals for two or 

more lines. Microsoft Word places the dropped character in a frame, so that you can easily move 

and resize it. 

 To create a large dropped initial capital word: 

 Position the cursor in the paragraph that you want to begin with large dropped initial 

capital word. 

 On the Format menu, Click Drop Cap 

 Click Dropped or Margin. 

 Select the number of lines to drop. 

 Click Ok. 

 To remove dropped characters: 

 Click the paragraph that contains the drop cap. 

 On the Format menu, Click Drop Cap 

 Click None, and then Ok. 

 

3.2 Paragraph Formatting 

 

The Formatting you do to change the appearance of a paragraph as a whole is paragraph 

formatting. Paragraph formatting includes: 

 Indenting a Paragraph. 

 Paragraph alignment 

 Line spacing. 

 Setting tab stops. 

 Bullets and Numbering. 

 Boarders and Shading. 
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Indenting a Paragraph  

 

Indenting refers to the left and right boundaries of the selected paragraphs with in a document. 

Paragraph indentation is quite different from the left and right page margins. Margins are the 

spaces between the edge of the text area and the edge of the paper where as indentation pushes 

the selected paragraph in or out from the left, right or both margins. 

 

You can use the Ruler, the Paragraph dialog box, and the Increase Indent and Decrease 

Indent buttons on the Formatting toolbar. Before indenting paragraph(s), place the Insertion 

Pointer anywhere in the paragraph you want to indent. 

 

Using the Decrease and Increase Indent buttons: This method of indenting of a paragraph is 

the fastest and easiest way of indenting paragraphs from the left or right margin by using a single 

tab stop. 

 

 To indent paragraphs using this method: 

o Position the pointer with in the paragraph or select the paragraphs you want to indent. 

o Click on Increase Indent button on the Formatting toolbar, to indent or push the 

paragraph to the next tab stop. 

o Click on Decrease Indent button, to indent the paragraph to the previous (left) tab stop. 

 

Using the ruler: this method provides you tools to indent a paragraph. It is used to indent the text 

either from the left or to the desired location by dragging the indent markers on the ruler. 

  

 

 

 

 

 

 

 

 

First line indent 

Hanging indent 

Left indent Right indent 
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 To indent paragraphs using the ruler: 

o Display the horizontal ruler if not displayed. 

o To indent the first line of a paragraph, drag the First line indent marker on the ruler. 

o To indent paragraphs from the left, drag the Left indent marker. 

o To indent paragraphs from the right, drag the Right indent marker. 

 

Using the Paragraph dialog box: it has the advantage of setting a precise measurement for 

paragraph indents. 

 

 To indent paragraphs using the paragraph dialog box: 

o Select the paragraph(s) you want to indent. 

o Choose paragraph from Format menu. 

o If not active, click on Indent and Spacing tab. 

o Under Indentation, specify the Left, Right, Hanging and First Line Indentation. 

o Click Ok. 

 

Changing Alignment  

 

Alignment refers to the way the right and left edges of a paragraph line up along the margins. A 

paragraph may be aligned: left (has a ragged edge at the right end), right (ragged on the left 

side), center (ragged on both sides), justified (has smooth edges on both sides). By default, word 

uses Left alignment. It is possible to change the alignment using both Formatting toolbar and 

the paragraph dialog box. 

 

 To align paragraphs using the formatting toolbar: 

o Select the paragraph(s) you want to align. 

o On the Formatting toolbar, click the appropriate alignment buttons (Left, Right, Center 

and Justified). 

 

 To align paragraphs using paragraph dialog box: 

o Select the paragraph(s) you want to align, or leave the cursor any where in the paragraph. 

o On the Format menu, click Paragraph. 

o Click Alignment tab and choose Left, Centered, Right, or Justified. 
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Setting Tab Stops 

 

Normally, it is the space bar that you use to push text to one character to the right. Sometimes 

you may need to align data on predetermined points across a line. In Word, Such points are 

known as Tab Stops. Word’s default tabs are positioned every half inches apart across the 

horizontal ruler. The Tab Key on the keyboard pushes the text to the next tab stop position to the 

right of the insertion point, and this distance is the distance between two tab stops. 

 

When you want to create a list with two or more columns of text, it is easier to replace the default 

tabs with custom tab stop positions at the exact locations where you want to line up your text. 

You can set tab stops (custom tab stops) using the Horizontal ruler or Tabs command from the 

Format menu and one of the four tab stop markers (left, center. right, decimal aligned). Use 

left tabs to align text to the left, right tabs to align text to the right, center tabs to center text 

across the tab, and decimal tabs to align numbers on the decimal point.  

 

 To set custom tab stops using Tabs dialog box: 

a. Place the cursor in which you want to set tab stop. 

b. On the Format menu, click Tabs.  

c. In the Tab Stop Position text box, type the position for the new tab.  

d. Under Alignment, select any of the alignment option boxes (Left, Center, Right, 

Decimal). 

e. Under Leader, click on the leader option you want. 

f. Click Set. 

g. Repeat steps C to F, if you set more than one tab stop. 

h. Click OK.  

 

 To set custom Tab stop using the ruler:  

 Select the paragraph in which you want to set tab stop. 

 Click Tab Alignment button from the left corner of the horizontal ruler until it changes to 

the type of tab you want. 

 Click on the graduation of the ruler where you want to set a tab stop.  
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 To clear or move tab stops:  

 Select the paragraph in which you want to clear or move the tab stop. 

 To move a tab stop, drag the tab marker to the right or left on the horizontal ruler as you 

need. 

 From the Format menu, choose Tabs, and then click on Clear or Clear All.  

 

Bullets and Numbering 

 

Lists in a document may be used to give emphasize that the order of the items in the list is 

important, or to indicate that each item differs from others. You usually use numbered lists to 

emphasize either the order, or the total number of items the list contains, and bullets to show that 

each one of the item is different from the others. 

If the lists are nested (lists with in a list), You can use nested numbering or bulleting. This is 

known as an Outline numbered style.  

 To add bullets or Numbering: 

 Position the cursor where you want to create before you enter text, or select the items You 

want to add bullets and numbering after you enter text. 

 From the Format menu, choose Bullets and Numbering.  

 To apply bullets, click Bulleted tab, or click Numbered tab to apply numbering.  

 Click OK.  

           Or 

 Click Bullets or Numbering button from the Formatting toolbar.  

 To create an outline Numbered style: 

 Choose Bullets and Numbering, from Format menu. 

 Click an Outline Numbered tab. 

 Select the outline numbered style you want.  

 Click OK, and then:  

 

o To Create 1
st
, 2

nd
, 3rd … levels to the right, press Tab key or click Increase Indent 

from the Formatting toolbar.  

o To go up one level to the left, press Shift + Tab, or click Decrease Indent.  
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Boarders and Shading  

 

Adding boarders and shading to your document makes attractive and enhances the document 

appearance. You can add boarders to any side of a paragraph, table, and you can add background 

shading to a table, or ordinary text. You can also add interesting or decorative page borders (Arts) 

to each page in a document. Though you cannot move the insertion pointer using a scroll bar, it is 

a best way to use a scroll bar to scroll through a long document easily. 

The simplest way to move the insertion pointer in a document is positioning the mouse pointer to 

a desired location and click. In addition to a mouse, you can also use the following keyboard 

options to quickly move around a document. 

 

 To add boarders:  

 Click in the paragraph to which you want to add boarders. 

 On the Format menu, Click Boarders and Shading.  

 Click Boarders tab, if it is not in front.  

 Scroll through the Style list, and click on the desired line style.  

 Use the Color drop-down list to change the color.  

 Click Ok. 

 To create a boarder around your page: 

 Choose Format, and then Boarders and Shading. 

 Click Page Boarder tab.  

 Specify the type of boarder you want.  

 Click Ok.  

 

3.3 Page Formatting 

 

Page formatting is a type of formatting which takes care of the overall appearance of the page. It 

includes: Headers and Footers, Margins, Page Breaks, Printing options,  
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Headers and Footers 

 

A header is a text that is automatically printed at the top of every page in a document, and footer 

is a text that is automatically printed at the bottom of every page if once created for a single page. 

Items like: document title, author’s name and address, current date, page number, a company 

logo, etc, are written in the header and footer areas.  

 

 To create a header and footer:  

 Choose Header and Footer from View menu. Word switches to print Layout view, and 

displays the Header and Footer toolbar (see the fig. Below).  

 With in the enclosed non-printing dashed line, enter the text; add a page number, current 

date, boarders, shading and other formats as you format your document.  

 Click Switch between Header and Footer, from the Header and Footer toolbar to go to 

the Footer and do the same for Header, as you like.  

 Click Close button from the Header and Footer toolbar to finish the session.  
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1. Insert page number     9. Switch between Header and Footer 

2. Insert Number of pages                 10. Show previous 

3. Format page Number             11. Show next 

4. Insert Date               12. Close Header and Footer 

5. Insert Time               13. Footer area 

6. Page set up              14. Header and Footer toolbar 

7. Show/Hide document text              15. Header area 

8. Same as previous 

 

Dividing a Document in to Sections.  

Various parts of a document may include various types of formatting. A formatting applied to a 

certain portion of a document some times may affect other part, which might have different 

formats. To avoid such a problem you have to divide the document in the sections, and each 

section can have its own format with out affecting the other sections. A section is a block of text 

that could be as small as a paragraph or as large as the entire document. This means, if you don’t 

divide the document in to sections, the whole document is considered to be one section. 

 A section break is a mark you inset to show the end of a section. A section break store the 

section formatting elements, such as margins, page orientation, columns, headers and footers, and 

sequence of page numbers. A section break appears as double dotted line that contains the word 

“Section Break”. You can also insert section breads to divide a document in to different sections 

so as to format differently. There are four types of section breaks: 

1. Next page: Inserts a section break, breaks the page, and starts the new section on the next 

page.  

2. Continuous: inserts a section break and starts the new section on the same page.  

3. Odd page: inserts a section break and starts the new section on the next odd-numbered page. 

4. Even page: Insert a section break and starts the new section on the next even-numbered page.  

 To Insert a section Break: 

 Click where you want to insert a section break.  

 On the Insert menu, click Break. 

 Under the Section Break Types, click the option that describes  where you want the new 

section to begin.  

 Click Ok.  
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4. Tables 

 

A table consists of vertical column and horizontal rows. The intersection of a column and a row 

is called a cell. You can fill cells with text and graphics. You can use tables to create rows and 

columns of information with out setting tabs, to align numbers in columns and then sort and 

perform calculations on them. 

 

4.1 Creating and Working with Tables 

 

It is possible to use the following three methods to create and modify tables. 

A. Using Table menu. 

a. Place the insertion pointer where you want to insert the table. 

b. From Table menu, choose Insert table. 

c. On the Insert Table dialog box, fix number of rows and columns. 

d. If you want, use the Auto Format command button to select and apply predefined table 

formats.  

e. Click on Ok. 

B. Using Standard toolbar. 

a. Click where you want to create a table. 

b. Click Insert Table icon on the Standard toolbar. 

c. Drag to select the number of rows and columns you want and click. 

C. Using Tables and Boarders toolbar. 

a. If not displayed, display the Tables and Boarders toolbar. 

b.Click Draw Table icon on this toolbar. The pointer changes to a pencil shape. 

c. Select the Line Style, Line Weight and Boarder Color from the toolbar. 

d. Draw from one corner to the diagonal corner of the table to define the extent of the entire 

table. 

e. Draw the column and row lines inside the rectangle. 

 

Note:  

 To erase a line or block of lines, click Eraser icon from the   toolbar and drag over the 

line. 
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Moving in a Table 

 

You can use the mouse to move in a table. To move to a specific cell using the mouse, simply 

place the I-beam in the desired cell, and click on the desired cell. You can also use the keyboard 

to move in a table. You can use the four arrow keys, although if a cell contains text the right and 

left arrow keys move the insertion character by character with in a cell. 

 

 To navigate in a table using the keyboard: 

 

 

 

 

 

 

 

4.2 Selecting Table Components. 

 

There are techniques of selecting the different components of a table before or after the text is 

inserted. 

 

To select Action 

A cell Click in the cells selection bar (the area to the left bottom corner of 

the cell text area). 

A range of cells Click in the selection bar and drag 

A row Double-click in the selection bar 

A column Place the I-beam on the top boarder of the desired column until it 

becomes a downward pointing arrow and click. 

A range of Columns Click and drag when the downward pointing arrow comes at the top 

boarder of the column. 

Entire Table Place the cursor any where in the table and from the Table menu, 

choose Select and click Table. 

 

To Move Press 

One cell to the right Tab 

One cell to the left. Shift + Tab 

Up one row. Up Arrow 

Down one row. Down Arrow 
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4.3 Changing Column Width or Row Height 

 

 To change column width or row height using Table boundaries: 

 Point to the vertical or horizontal column boundaries of the table. 

 When the pointer changed to double-head arrow, drag it to adjust the column width or 

row height of the selected row or column. 

 

 To change column width or row height using Table menu: 

 Click inside a cell,  and click  Table.  

 Click Table properties. 

 Click the Column or Row tab and choose the options you want. 

 

 To make the columns or rows in a table automatically fit the contents:  

 Click in the table. 

 Point to AutoFit on the Table menu.  

 Click AutoFit to Contents. 

 

You can also use the Move table column markers on the horizontal ruler or Adjust table row 

marker on the vertical ruler. 

 

4.4 Inserting and Deleting Rows and Columns 

 

 To add rows or columns to a table: 

 Select the same number of rows or columns as the number of rows or columns you want 

to insert. 

 From the Table menu, Choose Insert, and then click the options you want. 

 

Note:  

 You can also use the Draw table tool to draw the row or column you want. 

 To quickly add a row at the end of the Table, click the last cell of the last row and then 

press the Tab key. 
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 To delete a row or column: 

 Select the row or column to be deleted. 

 Click Delete from Table menu. 

 Click Row to delete a row, or Column to delete column. 

 

Merging Cells 

 

You can combine two or more cells in the same row or column in to a single cell. For example, 

you can merge several cells horizontally to create a table heading that spans several columns. 

 

 To merge cells: 

 Select the cells that you want to merge. 

 From Table menu, Choose Merge Cells. 

      Or 

 On the Tables and Boarders toolbar, Click Eraser  

 Drag the Eraser over the cell dividers you want to remove. 

 

 To change the orientation of text in a cell: 

 On the Format menu, Click Text Direction. 

 Click the Orientation you want. 

 

4.5 Table Formatting 

 

Table formatting includes bordering, shading, changing Fonts, and other attributes to each cell in 

a table. To change the font type, font style, and font color of cells content, select the cells that you 

want to format and click the commands accordingly. 

 

 To automatically format a table: 

 Click the table. 

 On the Table menu, Click Table AutoFormat. 

 In the Formats box, click the format you want. 

 Select the options you want. 
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 To repeat a table heading on subsequent pages: 

 Select the row or rows that you want to use as a table heading (the first row must be 

included). 

 On the Table menu, click Heading Rows Repeat. 

 

 To break a table across pages: 

 Click the row you want to appear on the next page. 

 Press CTRL + ENTER key. 

 

 To prevent a table row from breaking across pages: 

 Click the Table. 

 On the Table menu, click Table properties. 

 Click the Row tab.  

 Clear the Allow row to break across pages check box. 

 

4.6 Performing Calculations in a Table 

 

MS-Word enables us to perform calculations in a table. The calculation is done based on the cell 

address. Column word followed by row number addresses the cell. 

 

 To perform calculations in a table: 

 Click the cell in which you want the result to appear. 

 On the Table menu, click Formula. 

 If Word proposes a formula that you do not want to use, delete from the Formula box. 

 In the Paste Function box, click a function. 

 Type the cell references in the parenthesis. 

 In the Number Format box, enter a format for the number. 
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5. Creating Multicolumn Text 

 

Newspaper style column is also known as multicolumn text. Newspaper style columns are useful 

in creating documents such as newsletters, brochures, and reports. Text in newspaper style 

columns flows from the end of a column to the beginning of the next column. 

 

You can create two or more columns of equal or un equal width columns using either the 

Columns dialog box from the Format menu or the Columns button on the Standard toolbar. 

 

 To create newspaper style columns using the Columns dialog box: 

 Place the cursor where you want the columns to begin (if you are going to create a new 

newspaper style), or select the text if you have created the text. 

 From the Format menu, Click Columns. 

 Click on one of the predefined column formats under Presets, or specify the desired 

number of columns in the number of columns box. 

 In the Apply to drop-down list box, click on the place where you want to apply. 

 Click Ok. 

  

 To create newspaper style columns using the columns button: 

 Place the cursor where you want the columns to begin 

 Click on the Columns button in the Standard toolbar. 

 Click on the left most miniature column to specify a single column format, click on the 

second column to specify two columns, etc as you need. 

 

 To force the start of a newspaper column: 

  Switch to Print Layout view. 

 Click where you want to start the new column. 

 On the Insert menu, Click Break. 

 Click Column Break option button, and then Ok. 
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5. Working with Graphics  

 

Graphics in MS-word can be categorized into two: Drawing Objects and Pictures. 

 

6.1 Drawing Objects 

Drawing objects are part of MS-Word documents and can be created and improved using the 

tools in the Drawing toolbar. Drawing objects are: Auto Shapes, Curves, Lines and Word Art. 

Auto Shapes are ready-made shapes like circles, ellipse, rectangles, arrows, flow chart 

symbols, banners and callouts.  Any Auto Shape is used to draw a picture similar to it. 

 

 To draw a picture similar to an AutoShape: 

 Click Insert, Picture, & then Auto shape or click Auto shape icon from the Drawing 

toolbar. 

 Click on an Auto Shape you want to create similar to it. When you do so, your mouse 

changes to a cross shape. 

 Drag the cursor in your document until the picture attains the required size. 

 Release the mouse button and click outside the drawing. 

 

Once created or inserted, graphic objects can be positioned, selected and resized by dragging one 

of the small rectangles (known as sizing handles) on the rectangle surrounding the selected 

object. 

 

 To insert a Word Art object: 

 On the Drawing toolbar, click Insert WordArt. 

 Select the Word Art Style you want, and then click Ok. 

 In the Edit Word Art text dialog box, type the text you want to format. 

 Click Ok. 

 

Note: To add or change effects to the text, use the buttons on the Word Art and  

          Drawing toolbars. The Word Art toolbar appears when you click the Word Art  

          special text. 
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6.2 Pictures 

 

Objects created from other files are in general called pictures. Bitmaps, Scanned pictures, 

photographs, and clip art are examples of pictures. 

 To insert a picture from the clip Gallery: 

 Place your cursor where you want to insert a picture. 

 From Insert menu, choose Picture and then click on Clip Art. Or Click Insert Clip Art 

icon on the Drawing toolbar. 

 Click on the Category you want. 

 Click on the picture you want, and then Insert Clip on the menu icon that appears. 

 Click the Close button on the Clip Gallery title bar. 

 

Formatting a Picture 

 

To format a graphic object, right click the object and choose the Format <The name of the 

object you have selected> command from the short cut menu. The Format command is always 

followed by the name of the object you have selected. For example, if it is Word Art that you 

have selected to format, the Format command appears as Format Word Art. This way you can 

display the Format dialog box and set the options to modify the appearance of the object. 

 

7. Mail Merge 

 

Mail Merge is the process of merging or inserting personal information (usually addresses) from 

one document into another document and combines them into a single document. Commonly you 

can use the mail merge for mass mailing. You can use Mail Merge to create form letters; mailing 

labels, envelops, or catalogs. Commonly you can use Mail Merge for mass mailing specially in 

business and governmental organizations where communicating to a large number of other 

organizations, or individuals is part of their day-to-day activities.  
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Mail merge has the following main components and steps. 

 Open or create a Main document, which contains the generic information that you want to 

repeat in each form word, mailing label or catalog. 

 Open or create data source, which contains the data that varies in the merged documents, for 

example the name and address of each recipient of a form letter. 

 In the main document, inert merged fields, which are place holders that tell Microsoft Word 

where to insert data from the data source. 

 Merge data from the data source into the main document. Each row (record) in the data 

source produces an individual form word, mailing label, envelop or catalog item. You can 

send the merged documents directly to a printer or to e-mail addresses or fax numbers. 

 

 To merge the main document with the data source: 

 

1. Create the Main document 

1.1. To create the main document: 

1.1.1. Close any opened document, and start a new document. 

1.1.2. Save the document. 

1.1.3. On the Tools menu, choose Mail Merge. 

1.1.4. The Mail Merge Helper dialog box appears as follows. 

 

 

 

 

 

 

 

1.1.5. Under the Main document, click on Create button. Word displays a list of the 

different types of the main document you can create. 

1.1.6. Click on Form letters. Word asks what document you want to use as your main 

document. 

1.1.7. Since you have already started (opened) yours, click on Active window button. 

Word displays the name of the main document and activates the Get Data button. 
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2. Create the Data source. 

Because the data source is a simple database, you need to understand two database related 

terms to work with it: record and field. A record is all the information about one person in 

your data source. A field is one category of the information with in each record. Typical 

fields include first name, last name, company, address, city, etc. The first part of creating a 

data source to define what fields you want to use and the second part is to enter the data. 

 

2.1. To create a new data source: 

2.1.1. If you do not see the Mail Merge Helper dialog box, click in the main document, 

and then click Mail Merge on the Tools menu. 

2.1.2. Under Data Source, click Get Data, and then click Create Data Source. The 

Create Data source dialog box appears (Fig. Below). 

 

 

 

 

 

 

 

 

 

 

 

 

2.1.3. In the Field name text box, type the data fields and click Add Field Name button. 

2.1.4. When you finish specifying the data fields, click Ok. 

2.1.5. Name and Save the data source before you go to enter data. 
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2.1.6. Click Edit Data source. The Data Form dialog box appears (Fig. Below). 

 

 

 

 

 

 

 

 

 

 

 

2.1.7. Fill in the information (data) for each data record and press Enter key to go to the 

next field. 

2.1.8. Press the Enter key or click the Add New button to go to the next record. 

2.1.9. When you finish entering data records, save the data source by clicking View 

source, and then click Save from the standard toolbar. 

2.1.10. To return to the main document, click Mail Merge Main Document on the 

database toolbar. 

 

3. In the Mail Helper dialog box, click Merge the Data with the Document. 
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8. Templates and Styles 

 

8.1 Templates 

 

A template can be considered as a partially completed or structured form of a document stored as 

a file. Any document based on a template takes the structure and properties like Auto text entries, 

fonts, page layout, menus, special formatting and styles. 

 

Word contains templates that could be used to prepare various types of documents and every 

Microsoft word document is based on a template. For instance, when you start Microsoft Word or 

click New Bland Document, the new blank document is based on the Normal Template. The 

Normal Template is a general-purpose template that you can use for any type of document, while 

the template Words and Faxes in the New dialog box is used to prepare specific types of 

documents of Words and Faxes. 

 

8.2 Using Existing Templates and Creating New Templates. 

 

The primary benefit of using a template is that all, or at least some of the documents 

characteristics have been defined in advance. This enables you to create documents that have 

similar character and paragraph formats as well as similar page set ups, with out having to specify 

each parameter for each document. 

 

 To use a Template: 

 On the File menu, choose New. 

 Click on the tab that holds the template you want to use. 

 Select the template you want to use, and click Ok. 

 Create your document and save. 
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 To create a template: 

 From the File menu, click New. 

 Click on the General tab, if it is not active. 

 Click on Blank Document. 

 Click on the Template option button under Create New in the lower corner of the new 

dialog box, and click Ok. 

 Click Save As from the File menu, Document Template in the Type box, type the name 

and click Save. 

 Format the new template as you wish and click Save. 

 

8. 3 Using and Creating Styles. 

 

Styles are group of formats identified by a name that can define the appearance of various text 

elements of a document, such as headings, and body text. When you want to change the 

formatting of all the text of a particular element at once, you just change the style that is applied 

to that element. Styles make formatting your document easier. The style types are Character and 

paragraph styles.  Character style is a style that can only be applied on the selected text where as 

paragraph style is set of character and paragraph formats that can be applied on the active or 

selected paragraph. Once you create a paragraph style, you can select a paragraph and use the 

style to apply the whole group of formats in one step. 

 

In a list of styles next to the name, a character style is denoted by the symbol (a), and a paragraph 

style is denoted by a paragraph marker ( ). 

The Normal Style is a building block for other styles in the Normal Template. There are a 

number of other styles besides normal, available in the Normal Template. A few basic once are 

Default paragraph font, Heading 1, Heading 2, etc. 

 

 To apply paragraph or character style: 

 Click the paragraph or select group of paragraphs or words you want to change. 

 Click Style on the Format menu, or on the Formatting toolbar. 

 Choose a style from the style box and click Apply. 
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 To create a new character or paragraph style: 

 Click Format, Style, New. 

 Type the name for the style in the Name box, and click Character or Paragraph in the 

Style type box. 

 Select the other options you want and then click Format to determine the properties of 

the new style. 

 

 To remove a style: 

 Select the text. 

 Choose Normal Style from the Style box. 

 

 To modify a style: 

 On the Format menu, click Style. 

 In the Style box, select the style you want to modify. 

 Click Format, and then click the attribute you want to change like font and font size. 

 Click Ok. 
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9. Printing 

 

Printing is the process of having a hard copy of a document on to a paper, transparency, or film. 

Before you print your document, it is better to use the Print Preview command either from the 

standard toolbar or from the File menu. It is always a good practice to see the results of your 

work before you decide to get it finally printed. Print preview lets you see what the printed 

document will look like before you actually send it to the printer. Using print Preview is a great 

way to avoid wasting paper, because you can spot problems in your documents before you print.  

 

For example, you may discover that your page numbers are not displaying correctly or that 

margins are too much wide. 

 

 

 Follow the following steps to print your document. 

 

 To print one copy of the entire document, click on Print button in the standard toolbar. 

Or  

From the file menu, Click Print. The Print dialog box appears. 

 

1.1. Under Page Rage, Click on: 

1.1.1. All: To print the entire document. 

1.1.2. Current Page: to print the active page in which your cursor is placed. 

1.1.3. Pages: to print selected pages only. Enter the pages you want to print separated 

by hyphen, if the pages are consecutive or separated by a comma, if the pages are 

not consecutive. 

2.1 On the Number of copies box, enter the number of copies to be printed from each page. 

2.2 To print Odd or Even pages of a document, select Even pages or Odd pages options in 

the Print drop-down list box. This will help you to print the document on both side of a 

paper. 

2.3 Click Ok. 

 

 


